ShadowsMyst ShadowsMyst posted March 31, 2019, 21:56

Having problems with my NPC Farmers

I have had my NPC Farmers out and working for many months now. I came in one day and none are working, they just stand there doing I have contacted my Grids owner and told them what they needed to do...they did all that....but it was already set the way it should be, but they checked everything to be during the meantime I took out the smurf from the box and the listener...i wore both and saved the appearance....and still all my farmer does is stand there and when hit the keeps looking....please help...i have noticed in some grids the farmers are working, but yet in others they are not ....I also would like to know about the new version of your farm... version 2018.08.31 i can only find the .30 version...i am not sure i am even on the correct grid anymore with all the changes that metro did and osgrid if you can please send me the HG or what ever it is i need...I have a huge farm...both my sister and I...we love your work...and it keeps us very happy...thank you for that Satyr...*smiles* My grid owner said if possible if you have Skype if they could add you...they have their scripters looking into this matter also trying to figure out how to fix it...also the farmer does not give me any error notices or nothing...nothing at all...


eaglewealth 2 months ago
You can HG to ausgrid at or
I have few residents with farms too there and they have no issues with NPC farmers. have bit of issues of teleport to regions problems that i can't fix that cause of some ports closed with ISP.
eaglewealth 2 months ago
you need to tell grid owner put exactly the same as in line in osslenable.ini then after that restart grid and that will work.

Allow_osGetNotecard = true
Allow_osMessageObject = true

You need to change these settings or get your sim host to change them for you. The settings can be found either in your OpenSim.ini file (in the same folder where OpenSim.exe is) or in the config-include/osslEnable.ini. You must also have enabled NPCs in your region (Set Enabled = true in the [NPC] section of your OpenSim.ini file). If you use opensim 0.9, you can set these options to PARCEL_GROUP_OWNER instead of "true" which is safer. Important note: In latest version of opensim, the settings for OSSL functions are in the [OSSL] section , NOT in the [XEngine] section where they used to be.

When rezzing an NPC , it should appear right in front of the rezzer box. If they are rezzed at the edge of the sim instead, this means you have closed access to your parcel. This will cause the NPC to fail. Please allow access to the parcel (The NPC will use the group of the controller, so can allow group access), and make sure age restriction is off (that setting doesnt seem to work with NPCs). When the farmer NPC starts, he will look for a Well in a range of 90 meters, and complain if it can't find it.

NOTICE FOR Discovery Grid users: This grid uses a non-standard opensim, so you have to modify the script inside the NPC farmer rezzer script. Please find this string and remove it: " OS_NPC_NOT_OWNED | OS_NPC_SENSE_AS_AGENT |"
eaglewealth 2 months ago
I send you an instruction in private message shadowsMyst.
eaglewealth 2 months ago
Also there is section for ossl.ini to enable those in lines.

I have ossl.ini enabled properly after read that and then it all working.
eaglewealth 2 months ago
The grid owner need to make sure ossl.ini is enabled for NPC to work.
ShadowsMyst 2 months ago
It is..They rechecked again...but still not working anymore...they did work for many months..then just i contacted the grid owner and told them what to do and what needed to be done...they checked and said all is still added and nothing has we are not sure what is going was working on my sons grid and all of a sudden quit working also...he rechecked to make sure and everything was correct...but still doesn't work there either...